Skip to main content

Web application running on WAS server refresh url giving 404 not found issue

Problem statement :
Web application running on WAS server ( IBM Web Sphere Application Server is giving 404 error and once refreshing URL will work and after next refresh of web url it will give 404 and so on.

Solution :
In my application there are 3 web servers served via load balancer, We trouble shooted by stop two web servers and started one web server ( to make sure request always hits one server) after that we tested application URL refresh is working fine, So we concluded that there is no problem in first server, We did the same for by keeping second server start and first and third server down then we realised that all the web request to the second server is failing, then we did same for 3 rd server and observed they request to 3 rd server also failing.

Finally we observed that name resolution problem on the server. And fixed accordingly.




Comments

Popular posts from this blog

Angular cli ng command is not working

Problem : angular cli command  ng is not working

C:\Windows\System32>ng
'ng' is not recognized as an internal or external command,
operable program or batch file.

Solution :

update .npmrc file at C:\Users\{USERNAME}
with the below line

prefix=${APPDATA}\npm

warning: LF will be replaced by CRLF in

Problem :

The file will have its original line endings in your working directory







Solution:

step1) open .gitconfig file

step2) paste the below code


[core]
autocrlf = false
[filter "lfs"]
required = true
clean = git-lfs clean -- %f
smudge = git-lfs smudge -- %f
process = git-lfs filter-process


How to remove entity in jhipster and create fresh entities

Problem Statement : Not able to delete jhipster entity and wanted to entities freshly

Solution :

Step 1) Open command prompt and point to the jhipster project root

Step 2) Run  jhipster remove-entity

Step 3) Run jhipster

Step 4) Then import new jdl  using below command

jhipster import-jdl jhipster-jdl.jh

Step 5 ) Then Run  mvnw


Still Problem  : One of the entity may not load data and shows 500 error

Drop the tables in h2 database and let and do mvnw again.

To connect to local database Goto -> Administration -->Database --> Connect